This site requires JavaScript to be enabled
Welcome|
Recent searches
IE BUMPER

Configure Network Teaming: LACP on Unix - Solaris

Number of views : 3
Article Number : KB0012570
Published on : 2023-07-28
Last modified : 2023-07-28 19:10:02
Knowledge Base : IT Public Self Help

LACP Bonding

This page is to document instructions on how to configure LACP bonding for Solaris.

We are using LACP bonding in CRB (UDCC) so that networking can do maintenance on either side of the switch infrastructure without impacting our services.

An alternative to LACP bonding is IPMP which also pairs network cards but does not require the system to lose network connectivity and need a reboot to be fully implemented. Instruction for that can be found at https://wikis.utexas.edu/display/systems/IPMP+on+UNIX+-+Solaris

Solaris 10

This process can be done in 2 minutes or thereabouts.

Step

Commands 

Notes 

Prepare interfaces 

ifconfig e1000g0 down unplumb 
ifconfig e1000g1 down unplumb 

Network connections will drop 

Make aggregation device 

dladm create-aggr -d e1000g0 -d e1000g1 N 

N is an arbitrary number between 1 and 99 
The new interface will be "aggrN" (e.g. aggr1) 

Verify aggregation setup 

dladm show-aggr 

key: 1 (0x0001) policy: L4      address: 0:3:ba:d9:1a:a (auto) 
           device       address                 speed           duplex  link    state 
           e1000g0      0:3:ba:d9:1a:a    1000  Mbps    full    up      attached 
           e1000g1      0:3:ba:d9:1a:b    1000  Mbps    full    up      attached

Bring up aggregate interface

ifconfig aggr1 plumb up `cat /etc/hostname.e1000g0`; 
ifconfig aggr1 

Output should look like that from any normal active interface 

Enable LACP mode

dladm modify-aggr -l active -T long N

 

Check aggregation behavior 

dladm show-aggr -L 

key: 1 (0x0001) policy: L4      address: 0:3:ba:d9:1a:a (auto) 
                LACP mode: active       LACP timer: long 
    device    activity timeout aggregatable sync  coll dist defaulted expired
    e1000g0   active   short   yes          yes   yes  yes  no        no 
    e1000g1   active   short   yes          yes   yes  yes  no        no 

 

dladm show-aggr -s

key:1           ipackets   rbytes       opackets   obytes       %ipkts  %opkts 
        Total   7400008    4328912580   12053606   13413813380 
        e1000g0 4545797    2775001194   4030434    3082368604     61.4    33.4 
        e1000g1 2854211    1553911386   8023172    10331444776    38.6    66.6 
(You should see a distribution of packet traffic between the bonded interfaces) 

Configure for interface init at boot time 

mv /etc/hostname.e1000g0 /etc/hostname.aggr1; 
reboot 

That's it. 

 

 

 

 

Thank You! Your feedback has been submitted.

Feedback